Si estás aquí es porque estás afectado, pero no te preocupes, no se acaba el fin del mundo.

Este mes de enero del 2020 nos ha llegado a todos los usuarios que estamos registrados en Prestashop un email indicando que todas nuestras instalaciones son vulnerables a un bot llamado “XsamXadoo Bot”.

Este bot afecta a la herramienta PHPUnit.

Que es PHPUnit: Es una herramienta que usa o usaba mejor dicho ya que la versión 1.7.6.1 carece de ella y se usa por los desarrolladores para construir módulos. Lo normal es que no venga esta herramienta en la instalación final al usuario, por eso es poco probable que usted se encuentre esta herramienta en su instalación.

Si es cierto que nos hemos encontrado en dos tiendas de unos clientes este archivo y en concreto en el módulo autoupgrade. El resto de clientes estaban limpios. De todas formas, seguiremos revisando en los siguientes días que esté todo en orden y seguro.

Tal como indica Prestashop en el mensaje lo que hacer es lo que nos indican, que es:

  1. En su servidor, busque en la carpeta Vendedor en el nivel raíz de su sitio web PrestaShop
  2. Si la carpeta del proveedor contiene una carpeta “phpunit”, puede ser vulnerable a un atacante externo.
  3. Ahora puede simplemente eliminar la carpeta “phpunit” y su contenido.

Como ya he comentado anteriormente PrestaShop ha confirmado que hay varias tiendas que son vulnerables en este momento y que pueden ser atacadas en cualquier momento y varias tiendas ya han sido comprometidas.

La opción que tenemos para eliminar este directorio es entrando por FTP a la instalación, ir a la carpeta “vendor” y ver si se encuentra phpunit en este directorio, si fuera así tan solo elimínalo, no afecta nada a tu instalación o funcionamiento de la tienda.

También nos queda ir al directorio módulos e ir buscando dentro de cada uno de ellos la carpeta “vendor” y dentro de esta misma el phpunit. No afecta al funcionamiento del módulo.

Debes de tener en cuenta que todos tus módulos, prestashop y tu plantilla debe estar siempre actualizado. Estos problemas ocurren algunas veces por este motivo.

Recuerda también tener actualizada tu versión de PHP en tu servidor o alojamiento.

Un desarrollador a creado un modulo que te facilita toda la tarea que hemos comentado anteriormente. Nosotros lo hemos probado y nos ha funcionado correctamente. Cabe decir que ha sido en una instalación de prueba de una copia de seguridad de una tienda afectada.

No podemos asegurar que este modulo afecte o no a tu tienda, pero la verdad es que no hemos observado nada que pueda comprometer la seguridad de nuestra tienda online.

El blog del desarrollador del modulo lo puede ver en el siguiente enlace. Está en francés, tan solo puedes traducir su pagina o bien seguir los pasos que hemos comentado.

El modulo se llama slkphpunit v1.0.2 y se instala como cualquier otro modulo.

https://soluka.fr/blog/prestashop/prestashop-faille-phpunit-xsamxadoo-bot/

 

Esperamos que te sirva.

Share This

Compartir

Comparte esta publicación con tus amigos!